FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Search found 10 matches
Forum Index
Author Message
  Topic: SDL + OPENGL + Antialiasing
scooterman

Replies: 3
Views: 4472

PostForum: Derelict   Posted: Sun Sep 23, 2007 9:25 am   Subject: SDL + OPENGL + Antialiasing
Here is my init code:


DerelictSDL.load();
SDL_Init(SDL_INIT_VIDEO);

DerelictGL.load();

SDL_EnableUNICODE(1);

SDL_GL_SetAttribute(SDL_GL_MULTISAMPLEBUFFERS, 1);

SDL_GL_S ...
  Topic: SDL + OPENGL + Antialiasing
scooterman

Replies: 3
Views: 4472

PostForum: Derelict   Posted: Sat Sep 22, 2007 12:03 pm   Subject: SDL + OPENGL + Antialiasing
Hi again, I'm trying to add antialiasing support to my app, and by the SDL doc I should do this before initialize my screen:

SDL_GL_SetAttribute(SDL_GL_MULTISAMPLEBUFFERS, 1);

SDL_GL_SetAttr ...
  Topic: Problems loading shader...
scooterman

Replies: 7
Views: 5826

PostForum: Derelict   Posted: Sat Sep 22, 2007 8:53 am   Subject: Problems loading shader...
thanks vektorbosson, that worked well =)
  Topic: Problems loading shader...
scooterman

Replies: 7
Views: 5826

PostForum: Derelict   Posted: Thu Sep 20, 2007 4:28 pm   Subject: Problems loading shader...
Yeah, it is at runtime =D

And I've googled around and someone said that is because of garbage being read when loading the source, and that I should fill with zeros the array before copy the file, ...
  Topic: Problems loading shader...
scooterman

Replies: 7
Views: 5826

PostForum: Derelict   Posted: Wed Sep 19, 2007 8:21 am   Subject: Problems loading shader...
Thanks, that worked, but now I'm having problems compiling the code. I'm receiving these errors:
(1) : error C0000: syntax error, unexpected $undefined at token "<undefined>"
(1) : e ...
  Topic: Problems loading shader...
scooterman

Replies: 7
Views: 5826

PostForum: Derelict   Posted: Tue Sep 18, 2007 7:41 pm   Subject: Problems loading shader...
So, I've been trying to load a simple shader onto my GL app. On the specs, the function I should call after creating the shader object is glShaderSource.
It receives a char ** as the third parameter, ...
  Topic: Undefined symbol on compilling
scooterman

Replies: 38
Views: 32212

PostForum: gtkD   Posted: Sat Jun 02, 2007 11:07 am   Subject: Undefined symbol on compilling
Well, I was using the makeall.bat file. On my unix box everthing worked fine. I have to set any configuration to make it work in windows??

Thanks
  Topic: Undefined symbol on compilling
scooterman

Replies: 38
Views: 32212

PostForum: gtkD   Posted: Thu May 31, 2007 8:42 am   Subject: Undefined symbol on compilling
Hello, I'm trying to compile dui on windows with dmd. The library is created correctly, but when I try to make the tests I get a load of symbol undefined errors. Both release 3 and svn code gave the s ...
  Topic: Silly question
scooterman

Replies: 5
Views: 25638

PostForum: Schooner   Posted: Wed Feb 07, 2007 10:39 am   Subject: Silly question
Thanks, that worked perfectly. Another question:
I'm trying to create a simple test engine with gld, build it as lib, and then use the lib to create a independent program. But, when I try to import m ...
  Topic: Silly question
scooterman

Replies: 5
Views: 25638

PostForum: Schooner   Posted: Tue Feb 06, 2007 12:28 pm   Subject: Silly question
Sorry, but I'm kinda new on D and I'm having a little trouble on how to link schooner with the build tool. I've tried with the -IPath to gld.lib but it didn't worked. Someone can give me a hand??

...
 
Page 1 of 1
All times are GMT - 6 Hours
Jump to:  


Powered by phpBB © 2001, 2005 phpBB Group